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BÀI 18 NGÀY 20.8.2006 SOẠN THEO SÁCH CỦA KS TRẦN VIỆT AN 
XÁC LẬP CÁC THUỘC TÍNH TRANG :

Menu Modify > Page Properties > HT page Properties hiện ra > Nhấp Hạng Mục mà bạn muốn.

1. Chọn Mục APPEARANCE :

Menu Modify > Page Properties > HT page Properties hiện ra > Mục Appearance :

· Page Font : Chọn 1 Font mặc định của D.

· Size  : Chọn kích cở Tuyệt đối là 9,10,12…> Được phép             chọn tiếp Đơn vị Tính – Chọn kích cở tương đối là Small , Medium , Large …

· Text Color : Chọn màu cho Text.

· Background Color : Cho phép bạn Insert vào 1 Ảnh nằm dưới Text > Nhấp Nút Browse để tìm vị trí ảnh cần Insert vào > Ok. Khi bạn chọn Ảnh làm nền , nó sẽ thay thế màu nền .

· Repeat : Xác lập ảnh nền sẽ hiển thị như thế nào nếu nó không vừa toàn bộ trang. Chọn Repeat để xếp ngói ảnh theo chiều ngang ( Repeat –x ) và dọc ( Repeat-y ).

· Margin : Xác lập lề Phải – Trái – Trên – Dưới  của Trang > Chọn Đơn vị Tính > Ok .(H6+7).( Hình MH số 7 chưa nhập TEXT nên chưa có tác dụng ).
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2. Chọn Hạng Mục LINK  :

Menu Modify > Page Properties > HT page Properties hiện ra > Mục LINK .

· Link Font : Xác định Font mặc định ( D sẽ sử dụng Foont nầy trừ khi được ghi đề bởi 1 Style Sheet CSS ) – Xác định In đậm – In Nghiêng.

· Size : Giống trên.

· Link Color : Xác lập màu.

· Visited Links : Màu cho Text liên kết được tham quan . Có nghĩa là sau khi Link được mở ra Text liên kết – Nhấp tiếp vào Liên kết trong Text nầy ,ra text kế tiếp được xác định sẵn màu .

· Rollover Links : Đổi màu khi đặt con trỏ lên.

· Active Links : Nhấp Text hiện màu .

· Underline Style : Sẽ được gạch dưới.(H8).
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3. Chọn Hạng Mục  Headings của HT Page Properties :
Menu Modify > Page Properties  > Cột Category chọn Hạng Mục Headings , có các tùy chọn sau đây :

· Heading Font : Chọn Font ( Trừ Font được ghi đè bởi 1 Style Sheet CSS ) In đậm – In nghiêng.

· Heading 1 đến Heading 6 : Xác lập các Trình Ứng dụng kích cở và Màu , cho mỗi kích cở có tiêu đề chính ( Chương 5 sẽ viết về Định Nghĩa các Style HTML ). (H1).
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4. Title/Encoding :

Cho phép thay đổi Tiêu đề và một số Mục bí ẩn hơn trong 1 Trang Web :
· Title : Nhập Tiêu Đề lại.

· Document Type (DTD) : Cho phép bạn thay đổi <doctype> của Trang. Khi bạn thực hiện thay đổi ở đây , D thay đỗi mã của Trang ( Nếu cần thiết ) để làm cho nó tương thích với DTD được chọn .( Đang chọn mặc  định XHTML 1.0 Transition ) .

· Encoding : Xác lập kiểu mã hóa được sử dụng cho Trang ( đang chọn mặc định Western European ).

· Unicode Normaliazation Form và Include Unicode Signature (BOM) chỉ được kích hoạt khi bạn sử dụng Unicode UTF-8 làm kiểu mã hóa ( Chọn Menu Help > D ) để tìm hiểu thêm ). (H2).
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5. Tracing Image :
Thiết kế các Trang web bằng Chương Trình Adobe Photoshop hoặc Macromedia FireWorks , sau đó xuất ảnh đó và đưa vào D dưới dạng ảnh nền.

Tracing Image hướng dẫn thực hiện Ảnh đồ lại . Nó chỉ thực hiện trong D , nó không xuất hiện khi bạn xem trước trong một trình duyệt.

Có 2 tùy chọn :

· Tracing Image : Nút Browse để đi đến ảnh.

· Transparency : Thanh trượt chỉnh độ mờ đục cho ảnh > Apply > Ok. (H3).


Unicode Normaliazation Form và Include Unicode Signature (BOM) chỉ được kích hoạt khi bạn sử dụng Unicode UTF-8 làm kiểu mã hóa ( Chọn Menu Help > D ) để tìm hiểu thêm ).

Setting options in the New Document Preferences dialog box

The purpose of this dialog box is to establish a default new document type and preferences.

To set new document preferences:

1. Set the options you want to apply: 

· To set a default document to open, under the Default Document pop-up menu, select a document on which to base new pages that you create in the site. 

· If you select HTML as the default document, you can use the Default Extension text box to specify the file extension you prefer (.htm or .html) for new HTML pages created in Dreamweaver. For more information, see Setting the default file extension of new HTML documents. 

	NOTE
	 
	This option is disabled for other file types.


· To make new pages XHTML-compliant, select one of the XHTML document type definitions (DTD) from the Default Document Type (DTD) pop-up menu. 

For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu. For more information, see About the XHTML code generated by Dreamweaver.

· To set an encoding for documents, use the Default Encoding pop-up menu. 

Default Encoding specifies the encoding to be used when a new page is created, as well as when a document is opened that does not specify any encoding. For more information, see Understanding document encoding.

If you select Unicode (UTF-8) as the document encoding, entity encoding is not necessary because UTF-8 can safely represent all characters. If you select another document encoding, entity encoding may be necessary to represent certain characters. For more information on character entities, see www.w3.org/TR/REC-html40/sgml/entities.html.

· If you select Unicode (UTF-8) as a default encoding, select a Unicode Normalization Form. 

There are four Unicode Normalization Forms. The most important is Normalization Form C because it's the most common one used in the Character Model for the World Wide Web. Macromedia provides the other three Unicode Normalization Forms for completeness.

In Unicode, there are some characters that are visually similar but can be stored within the document in different ways. For example, "ë" (e-umlaut) can be represented as a single character, "e-umlaut," or as two characters, "regular Latin e" + "combining umlaut." A Unicode combining character is one that gets used with the previous character, so the umlaut would appear above the "Latin e." Both forms result in the same visual typography, but what is saved in the file is different for each form.

Normalization is the process of making sure all characters that can be saved in different forms are all saved using the same form. That is, all "ë" characters in a document are saved as single "e-umlaut" or as "e" + "combining umlaut," and not as both forms in one document.

For more information on Unicode Normalization and the specific forms that can be used, see the Unicode website at www.unicode.org/reports/tr15.

· If you select Unicode (UTF-8) as a default encoding, you can include a Byte Order Mark (BOM) in the document by selecting the Include Unicode Signature (BOM) option. 

A BOM is 2 to 4 bytes at the beginning of a text file that identifies a file as Unicode, as well as the byte order of the following bytes. Because UTF-8 has no byte order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required. 

· Deselect the Show New Document Dialog Box on Control+N (Windows) ("on Command+N" for Macintosh) option to automatically create a new document of the default document type when you use the key command. 

2. Click OK. 

Related topics

· Setting a default new document type 

Setting the Page Properties (Document Type) dialog box options

The purpose of this dialog box is to select a document type when none is specified for a document. It lets you specify the document encoding type that is specific to the language used to author the web page. You can also specify which Unicode Normalization Form to use with that encoding type.

Document Type (DTD) specifies a document type definition. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu. For more information, see About the XHTML code generated by Dreamweaver.

Document Encoding specifies the encoding used for characters in the document. For more information about document encoding, see Understanding document encoding.

If you select Unicode (UTF-8) as the document encoding, entity encoding is not necessary because UTF-8 can safely represent all characters. If you select another document encoding, entity encoding may be necessary to represent certain characters. For more information on character entities, see www.w3.org/TR/REC-html40/sgml/entities.html.

Unicode Normalization Form is only enabled if you select UTF-8 as a document encoding. There are four Unicode Normalization Forms. The most important is Normalization Form C because it’s the most common form used in the Character Model for the World Wide Web. Macromedia provides the other three Unicode Normalization Forms for completeness.

In Unicode, there are some characters that are visually similar but can be stored within the document in different ways. For example, "ë" (e-umlaut) can be represented as a single character, "e-umlaut," or as two characters, "regular Latin e" + "combining umlaut." A Unicode combining character is one that gets used with the previous character, so the umlaut would appear above the "Latin e." Both forms result in the same visual typography, but what is saved in the file is different for each form.

Normalization is the process of making sure all characters that can be saved in different forms are all saved using the same from. That is, all "ë" characters in a document are saved as single "e-umlaut" or as "e" + "combining umlaut," and not as both forms in one document.

For more information on Unicode Normalization and the specific forms that can be used, see the Unicode website at www.unicode.org/reports/tr15.

Include Unicode Signature (BOM) lets you include a Byte Order Mark (BOM) in the document. A BOM is 2 to 4 bytes at the beginning of a text file that identifies a file as Unicode, and if so, the byte order of the following bytes. Because UTF-8 has no byte order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required. 

Convert Document or Reload Document lets you convert the existing document, or reopen it using the new encoding.

Setting the Title/Encoding Page Properties options

The Title/Encoding Page Properties category lets you specify the document encoding type that is specific to the language used to author your web pages as well as specify which Unicode Normalization Form to use with that encoding type.

Title specifies the page title that appears in the title bar of the Document window and most browser windows. See Changing the document title.

Document Type (DTD) specifies a document type definition. For example, you can make an HTML document XHTML-compliant by selecting XHTML 1.0 Transitional or XHTML 1.0 Strict from the pop-up menu. For more information, see About the XHTML code generated by Dreamweaver.

Encoding specifies the encoding used for characters in the document. For more information about document encoding, see Understanding document encoding.

Unicode Normalization Form is only enabled if you select UTF-8 as a document encoding. There are four Unicode Normalization Forms. The most important is Normalization Form C because it’s the most common form used in the Character Model for the World Wide Web. Macromedia provides the other three Unicode Normalization Forms for completeness.

In Unicode, there are some characters that are visually similar but can be stored within the document in different ways. For example, "ë" (e-umlaut) can be represented as a single character, "e-umlaut," or as two characters, "regular Latin e" + "combining umlaut." A Unicode combining character is one that gets used with the previous character, so the umlaut would appear above the "Latin e." Both forms result in the same visual typography, but what is saved in the file is different for each form.

Normalization is the process of making sure all characters that can be saved in different forms are all saved using the same from. That is, all "ë" characters in a document are saved as single "e-umlaut" or as "e" + "combining umlaut," and not as both forms in one document.

For more information on Unicode Normalization and the specific forms that can be used, see the Unicode website at www.unicode.org/reports/tr15.

Include Unicode Signature (BOM) lets you include a Byte Order Mark (BOM) in the document. A BOM is 2 to 4 bytes at the beginning of a text file that identifies a file as Unicode, and if so, the byte order of the following bytes. Because UTF-8 has no byte order, adding a UTF-8 BOM is optional. For UTF-16 and UTF-32, it is required. 

LINK DOWN 17 Bài nầy : 

http://utbinh.com/AUGUST/DREAMWEAVER8.rar
Dung Lượng 9.67 MB. Giải nén bạn sẽ có nội dung các bài dưới đây
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