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  FRONTPAGE 
2003 

TẠO FORM 
 
BÀI 41 NGÀY 21.7.2009 SOẠN THEO DỈA SGDG 
 
MỘT FORM CỦA TRANG WEB GỒM 1 HAY NHIỀU PHẦN TỬ ĐỂ TIẾP NHẬN 
DỮ LIỆU CỦA NGƢỜI DÙNG VÀ MỘT VÀI PHƢƠNG PHÁP XỬ LÝ DỮ LIỆU 
NHẬP . FORM ĐƠN GIẢN NHẤT GỒM 1 TRƢỜNG NHẬP ĐƠN VÀ 1 NÚT GỞI  
KẾT QUẢ XỬ LÝ .MÀN HÌNH NHẬP LIỆU LÀ NHỮNG Ô NHẬP LIỆU – NÚT 
KIỂM TRA – DẠNG LIỆT KÊ DANH SÁCH .ĐÂY LÀ CÁCH GIAO TIẾP GIỮA 
NGƢỜI DUYỆT VỚI NGƢỜI CHỦ TRANG WEB . NGƢỜI DUYỆT CÓ THỂ 
NHẬP TỪ BÀN PHÍM CÁC THÔNG TIN , ẤN CHUỘT VÀO CÁC NÚT ĐIỀU 
KHIỂN HAY CHỌN CÁC THÔNG TIN TỪ NÚT THẢ XUỐNG . SAU ĐÓ GỞI 
THÔNG TIN BẰNG CÁCH ẤN CHUỘT VÀO NÚT SUBMIT HOẶC SỬA LẠI DỮ 
LIỆU NHẤN NÚT RESET .TẬP TIN CHỨA THÔNG TIN CHÍNH XÁC SẼ GỞI 
KÈM VỚI TRANG HOẶC THEO ĐỊA CHỈ EMAIL . THƢỜNG CÁC MÀN HÌNH 

NHẬP LIỆU GỒM : HỌ TÊN , ĐỊA CHỈ , SỐ ĐIỆN THOẠI , EMAIL VÀ TẤT CẢ 
NHỮNG THÔNG TIN KHÁC CẦN GỞI ĐI . 
 
MỤC LỤC :  

 
BÀI 1 : BIỂU MẪU . 

BÀI 2 : HỘP VĂN BẢN 1 DÒNG . 
BÀI 3 : NÚT CHỌN LỰA ( OPTION BUTTON ) . 
BÀI 4 : HỘP KIỂM TRA ( CHECK BOX ) . 

BÀI 5 : HỘP LIỆT KÊ ( DROP DOWN MENU ) . 
BÀI 6 : Ô NHẬP LIỆU NHIỀU DÒNG . 

BÀI 7 : THAY TÊN SUBMIT , RESET. 
BÀI 8 : CÁCH GỞI BIỂU MẪU . 

 

THAM KHẢO 
 
Tạo Form tham khảo Trang web : http://www.tizag.com/htmlT/forms.php . Cách sử 
dụng HTML  : Chọn 1 Kiểu Form > Copy Code > Nút Code trong FP > Paste vào . 

Chèn Form vào Blog – web :  
http://utbinh.com/MAY08/100508/ChenFormvaoBlogWeb.doc 

Xem bài hƣớng dẫn tạo Form PHP : 
http://utbinh.com/MAY08/100508/FormEmailPHP.doc 

Kết quả thực tập : http://utbinh.com/ykien/goithu.php 

http://www.tizag.com/htmlT/forms.php%20.%20C�ch
http://utbinh.com/MAY08/100508/ChenFormvaoBlogWeb.doc
http://utbinh.com/MAY08/100508/FormEmailPHP.doc
http://utbinh.com/ykien/goithu.php
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Giáo trình PHP&MySQL của SSDG : 
http://download533.mediafire.com/wmctyszctyng/wdvxzz1g2an/LaptrinhPHP_SSDG.part1_YoDownload.Net.rar 
http://download378.mediafire.com/wnagwaxt05vg/atcjknxnjej/LaptrinhPHP_SSDG.part2_YoDownload.Net.rar 
http://download375.mediafire.com/jsugiy0wm5lg/njbwmybgtbm/LaptrinhPHP_SSDG.part3_YoDownload.Net.rar 
http://download280.mediafire.com/m9cefovmzwtg/5cwdywzdhwd/LaptrinhPHP_SSDG.part4_YoDownload.Net.rar 

Cách giải nén : 
Nhấp Phải lên part1> Open > Nhấp Công Cụ Extract To > Cột Trái chọn Keep Broken 
Files > Ra 1 Folder > Nhấp lên Fo;der này > Có 1 File Ảnh > Nhấp Phải lên > Open 

With > Images Files > Hiện ra Chƣơng Trình Ghi Dỉa Nero ( Với điều kiện trƣớc đó bạn 
đã cài Chƣơng Trình Ghi Dỉa Nero ) . 

 

TẠO 1 WEBSITE 
 
Mở FP > File > Create a new normal page > Đã hiện ra Cửa Sổ Soạn Thảo với Tab 

new_page_1.htm đang mở và con trỏ đầu Trang  . 
 

1.TẠO FORM MỚI 
 

Menu Insert > Form > Form > Hiện ra : 

 Nút Submit : Khi nhấp lên chấp nhận nhội dung của Form và cho phép 

Ngƣời Duyệt Web gởi thông tin , dữ liệu trong Form về Ngƣời Chủ Trang 
Web . 

 Nút Reset : Nhấp lên để xóa dữ liệu viết sai , bắt đầu viết lại hay làm sạch 

Ô nhập liệu để nhập mới . 

 Đƣờng Khuông viền không liền nét đại diện cho giới hạn trong Form . Mọi 
thành phần của Form nằm trong Khuông này . (H1). 

 
 

 
  
 

 
 

 
 

 

2.HỘP VĂN BẢN MỘT DÒNG 
 
 

Hộp văn bản 1 Dòng là phần chính của hầu hết của những Form nhập trực tuyến . Ô 
nhập liệu 1 Dòng dùng nhập các thông tin ngắn nằm gọn trong 1 Dòng  thƣờng là họ 
tên , địa chỉ , số điện thoại . 

 
1. Nút Enter để mở rộng Text Box > Nhấp con trỏ đầu Dòng > Nhập : Họ và tên : > 

Insert > Form > Textbox . 
2. Hiện ra Ô nhập liệu , nhấp lên nó > Hiện ra 6 nút đen nhỏ > Nới rộng Hộp này 

bằng cách rê nút > Nhấp Phải chọn Form Field Properties >  HT Text Box 
Properties , Nhập : hovaten cho Ô name – Width in Characters nhập 30 . 
 

3. Giải thích HT Text Properties : 
 Name : Định tên cho Ô nhập liệu , thƣờng đặt gần giống tên hƣớng dẫn . 

http://download533.mediafire.com/wmctyszctyng/wdvxzz1g2an/LaptrinhPHP_SSDG.part1_YoDownload.Net.rar
http://download378.mediafire.com/wnagwaxt05vg/atcjknxnjej/LaptrinhPHP_SSDG.part2_YoDownload.Net.rar
http://download375.mediafire.com/jsugiy0wm5lg/njbwmybgtbm/LaptrinhPHP_SSDG.part3_YoDownload.Net.rar
http://download280.mediafire.com/m9cefovmzwtg/5cwdywzdhwd/LaptrinhPHP_SSDG.part4_YoDownload.Net.rar
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 Initial value : Nội dung khởi tạo của Ô Nhập liệu . 

 Width in Characters : Số ký tự cho chiều dài Ô . 
 Tab Orders : Trình tự đến đƣợc Ô , khi nhấp Phím Tab . 

 Password Field : Chọn NO .( Chọn YES , khi nhập dữ liệu , từng ký tự nhập 

đƣợc mã hóa thay bằng dấu “* . Chọn No , Ô nhập dạng bình thƣờng )(H2)  
 

 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 
 

 

3.NÚT CHỌN LỰA ( OPTION BUTTON ) 
 
Trong một nhóm các nút , bắt buộc chọn 1 và chỉ 1 mà thôi . Các Nút thuộc cùng nhóm 

phải có cùng tên nhóm ( Group ) chỉ khác nhau về giá trị . 
 

1. Emter để định vị con trỏ dƣới chữ Họ và Tên > Nhập : Giới Tính : > Insert > 
Form > Option Button > Hiên ra Nút , nhập Nam sau Nút  > Insert > Form  
Option Button > Hiện ra Nút > Nhập Nữ sau nút . Có thể Copy Nút > Paste kế 

bên cũng đƣợc . 
2. Nhấp Phải vào Nút Nam > Form Field Properties > HT Option Button Properties 

hiện ra , Group name nhập : Giới tính – Value mặc định V1 > Ok > Nhấp Phải vào 
Nút Nữ > Lập lại bƣớc trên – Value mặc định V2 > Ok . 
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3. Giải thích :  
 

 Group name : Tên nhóm nút . các Nút cùng nhóm phải có cùng tên . 

 Value : Giá trị của từng Nút đơn trong Nhóm . 
 Initial State : Trạng thái ban đầu của Nút . 

 Selected : Nút đƣợc chọn . 

 Not Selected : Nút chƣa đƣợc chọn . 
 Tab Orders : Trình tự đến đƣợc Ô khi nhấn Phím Tab . 

 

 

4.HỘP KIỂM TRA (CHECK BOX ) 
 

 

Loại Check Box thƣờng đƣợc nhóm lại , có cùng tên nhóm , khác nhau về giá trị của 
từng Nút Check trong Nhóm . tƣơng tự nhƣ Radio Button . 
 

1. Nhấp con trỏ sau chữ Nữ > Enter > Đã chỉ định con trỏ đầu dòng dƣới chữ Giới 
Tính > Nhập : Sở Thích : > Insert > Form > Checkbox > Đã hiện ra Nút kiểm , 

nhập Bóng Đá .> Insert > Form > Checkbox > Đã hiện ra Nút Kiểm , nhập Bóng 
Bàn . 

2. Nhấp Phải Nút Kiểm của Bóng Đá > Form Field Properties > Name nhập : 

bongda > Ok . 
3. Nhấp Phải Nút Kiểm của Bóng Bàn > Form Field Properties > Name nhập : 

bongban > Ok . 
4. Bạn tạo thêm Nút Kiểm và nhập tên : Cầu Mây và nhập Name vào . 

5. Value : Giá trị của từng Nút Check – Style : Lựa chọn Font chữ khi nhập . 
 
 

 
 

 
 

 
 
 

 
 

 
 
 

 

5.HỘP LIỆT KÊ 
 
Hộp Liệt Kê dùng chứa 1 Danh sách các nội dung theo từng dòng và đƣợc cuộn lại 

thành 1 dòng .Khi cần xem nhấp nút xổ xuống để hiện ra danh sách thả xuống , nhấp 
lên 1 văn bản để bật ra nội dung của văn bản đó . 

 
1. Nhấp con trỏ sau chữ Bóng bàn > Enter > Đã chỉ định con trỏ dƣới chữ Sở Thích 

> Nhập Trình Độ : > Insert > Form > Drop_Down Box > Hiện ra Hộp Liệt Kê . 
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2. Nhấp đúp Hộp Liệt Kê để mở thuộc tính > HT Drop_Down Box Properties hiện ra 
nhấp Nút Add > Mục Choice nhập : Tiểu Học ( Nếu không hiện ra chữ Việt nhấp 

Nút Style để chỉnh lại Font ) > Ok , đóng HT Add Choice > Ok đóng HT DBP . (H5)  
 

 
 

 
 
 

 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 

 
Giải thích Hộp Thoại Add Choice : 
 

 Choice : Tên Thành Phần sẽ xuất hiện trong danh sách . 

 Specify Value : Giá trị trả về khi Thành Phần đƣợc chọn trong danh sách  . 
 

Giải thích Hộp Thoại Drop_Down Box Properties : 
 

 Choice : Danh sách liệt kê các Thành Phần . 
 Height : Độ cao dòng liệt kê . 

 Allow Multiple Selection : Hình thức chọn nhiều Thành Phần . 

 Yes : Cho phép chọn nhiều , cùng lúc . 
 No : Không cho đƣợc nhiều , chỉ một . 

 Tab Ordest : Trình tự đến đƣợc Ô khi nhấp Phím Tab . 

 Add : Thêm Thành Phần vào danh sách . 

 Modify : Thay đổi nội dung Thành Phần . 
 Remove : Loại bỏ Thành Phần ra khỏi danh sách . 

 Move Up : Đổi trình tự , thành phần chọn lên trên . 

 Move Down : Thành Phần chọn xuống dƣới . 
 

 
3. Nhấp đúp vào Hộp Liệt Kê > Lập lại các bƣớc trên , nhập : Trung Học > Bạn đã 

thấy trong Mục Choice liệt kê các văn bản mà bạn đã Add . 
4. Lập lại các bƣớc trên , nhập : Đại Học . (H6) . 
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1. Nhấp Nút Preview và nhấp Nút xổ xuống . 

 
 

6.Ô NHẬP LIỆU NHIỀU DÒNG 
 

Ô nhập Liệu Nhiều Dòng ( Text Area ) dùng nhập các thông tin , dữ liệu dài nhiều dòng 
thƣờng dùng nhập các ghi chú , ý kiến , cảm nghĩ , thắc mắc của Ngƣời Duyệt Web . 

 
1. Định vị con trỏ > Nhập : Ghi Chú : > Insert > Form > Text Area > Nhấp đúp lên 

Text Area Box mới chèn > HT Text Area Box Properties  hiện ra > Hàng Name 

nhập : ghichu > Width In Characters nhập 30 > Number of lines nhập 3 > Ok . 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 

 
 
 

Giải thích : 
 

 Name : Tên Ô nhập liệu nhiều dòng . 
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 Initial value : Giái trị khởi tạo của Ô . 

 Width In Characters : Số Ký tự cho chiều dài Ô . 
 Number of Lines : Số dòng hiển thị của Ô . 

 Tab Order : Trình tự đến dƣợc Ô khi nhấp phím Tab . 

 

7.THAY TÊN NÚT SUBMIT , RESET 
 
Bạn có thể thay tên 2 Nút này theo ý thích của bạn . Việc thya tên rất đơn giản , vỉ vài 

bƣớc là xong  
 

1. Nhấp đúp Nút Submit > HT Bush Button Properties hiện ra > Hàng Name nhập : 
Dongy > Hàng value/ label nhập : Đồng Ý > Ok  

2. Tƣơng tự , nhập ; xoa trong Name và nhập : Xóa trong Value/label  Ok . 

 
 

 
 
 

 
 

 
 

 
 
 

 
8.CÁCH TẠO 1 KIỂU FORM  

 
 
 
 
 
 
 
 
 
 
 

 
TẠO 3 HỘP TEXTBOX : Theo KS đậu Quang Tuấn . 
 

1. Chỉ định vị trí con trỏ > Insert > Form > Form > Nhấp Nút Submit > Phím Delete 
> Tiếp tục xóa Nút Reset . 

2. Insert > Form > Label > Ra HT nhấp Ok > Nhập : CHƢƠNG TRÌNH CHO CÁC 

CHÁU LÀM TOÁN > Format văn bản này > Enter nhiều lần nới rộng Khuông lớn 
ra . 
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3. Insert > Form > Label > Nhập : Nhập vào số a = > Insert > Form > Textbox > 
Enter . Đã tạo 1 hộp văn bản . 

4. Insert > Form > Label > Nhập : Nhập vào số b = > Insert > Form > Textbox > 
Enter . Đã tạo 1 hộp văn bản . 

5. Insert > Form > Label > Nhập : Kết quả : > Insert > Form > Textbox > Enter . 
Đã tạo 1 hộp văn bản . Bạn canh chỉnh sao cho 3 Hộp TextBox đều thẳng hàng . 

 
TẠO 4 PUSH BUTTON : 
 

1. Insert > Form > Push Button > Nhấp đúp lên nút > Name nhập : cong – 
Value/label nhập : a+b > Ok . Đã có nút nhấn a+b . 

2. Insert > Form > Push Button > Nhấp đúp lên nút > Name nhập : tru – 
Value/label nhập : a-b > Ok . Đã có nút nhấn a-b . 

3. Insert > Form > Push Button > Nhấp đúp lên nút > Name nhập : nhan – 

Value/label nhập : a*b > Ok . Đã có nút nhấn a*b . 
4. Insert > Form > Push Button > Nhấp đúp lên nút > Name nhập : chia – 

Value/label nhập : a/b > Ok . Đã có nút nhấn a/b . 
 

Thông thƣờng ngƣời ta tạo 1 Form gồm các công cụ để Ngƣời Xem nhập vào Họ và Tên 
địa chỉ , nơi công tác , các khung để nhập lời góp ý , đăng  ký hoặc nhắn nhũ một điều 
nào đó . 

 
CHỌN CÁCH XỬ LÝ MỘT FORM : 

 
Nhấp chuột vào trong Khuông Form > Insert > Form > Properties . Nếu Server của 

bạn ( Host Mua hoặc Host Free của bạn )  có sử dụng FrontPage Extensions  thì bạn 
hãy chọn : 
Send To > Trong File name hãy chỉ định vị trí của File sẽ chứa dữ liệu nhận đƣợc từ 

Ngƣời xem ( Ở đây bạn chỉ định chứa trong Folder private ) . Nếu Server không có 
FrontPage Extensions hãy nhấp chọn Send To Other và trao đổi với Ngƣời Quản Lý hệ 

thống về việc một Script ( Chọn Custom … Script ) > Ok . 
 

 
 8.CÁCH GỞI BIỂU MẪU  
 

 

Các bạn cần liên hệ với nhà cung cấp Dịch Vụ Internet (ISP) hay Ngƣời Quản Lý Trang 
Web  để xác lập tiến trình xử lý các Biểu mẫu . 
 

1. Định con trỏ trong Khuông của Form > Insert > Form > Properties > Nếu hệ 
FrontPage Extensions có thì chọn Send To : 

 File name : Chỉ rõ Đƣờng dẫn và Tên tập tin chứa nội dung kết quả Form  . 
 Email Address : Gởi thông tin theo hệ thống Mail Services . 

Nếu không có FrontPage Extensions thì chọn Send To Database , Send To Other 

và chọn ký mã truyền theo hƣớng dẫn của Ngƣời Quản Trị mạng Web của bạn 
trên Internet . 
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Theo nhƣ utbinh nhận xét trong Giáo Trình Thiết kế Web bằng Front Page 2003 này 

khi tạo Form bạn không thể nhận đƣợc ý kiến phản hồi đƣợc mặc dù trong Trang Web 
có thể hiện phần nội dung Form của bạn đã thiết kế và đã đƣợc Ngƣời Duyệt Web nhập 
văn bản ý kiến – cung cấp dữ liệu vào . Lý do : Trong Server không có cài đặt 

FrontPage Extensions nên các Form không hoạt động và bạn không nhận đƣợc ý kiến 
phản hồi . 

Nhƣ vậy bài viết này chỉ hƣớng dẫn tìm hiểu cho các bạn cách tạo Form mà thôi .  


